ClamWin AntiVirus:
Руководство пользователя

Manual © 2004 Russell Phillips
Русский перевод: Aidar Bikmullin
ClamWin program code © 2004 Alex Cherney

www.clamwin.org


Введение

ClamWin - графический интерфейс свободного антивируса ClamAV для операционных систем семейства Microsoft Windows. Программа поставляется в виде удобного инсталлятора. На данный момент доступна только английская версия ClamWin.

Особенности программы:

  • Планировщик предназначен для автоматической проверки в заданное время.

  • Автоматическое обновление вирусных баз через Интернет

  • Автономный вирусный сканер

  • Интеграция с Проводником Windows позволяет проверить файл из его контекстного меню

  • Интеграция с Microsoft Outlook для проверки входящей и исходящей почты

Пожалуйста, обратите внимание, что ClamWin не содержит резидентного сканера, проверяющего файлы при обращении к ним. Вы должны вручную проверить файл, чтобы обнаружить вирус. Однако, при включенной интеграции с Microsoft Outlook, зараженное письмо будет удалено автоматически.


Установка

Загрузите последнюю версию антивируса ClamWin. Закройте все запущенные программы, затем запустите загруженный файл двойным щелчком по его значку. Если у вас уже установлен ClamWin, Вы можете модернизировать его, просто запустив программу установки более новой версии и установив ее поверх существующей. В этом случае, программа установки обнаружит запущенный ClamWin. Вы должны остановить ClamWin перед продолжением установки.

После нажатия кнопки Next на начальном экране будет отображена лицензионная информация. Данная программа выпущена согласно Стандартной Общественной Лицензии GNU. Вы должны принять лицензионное соглашение для продолжения установки. Программа установки также установит двоичные файлы от Cygwin (www.cygwin.com) и Clam Antivirus (www.clamav.net), также распространяемые согласно Стандартной Общественной Лицензии GNU.

Затем, вы должны будете указать папку для установки ClamWin. В большинстве случаев нет необходимости изменять предложенный по умолчанию путь установки и изменять его без особой необходимости не рекомендуется. Далее, вы должны выбрать тип установки и устанавливаемые компоненты.

Три опции (Cygwin, ClamAV и ClamWin) – выделены серым цветом и устанавливаются всегда. Эти файлы необходимы для нормальной работы программы. Другие опции описаны ниже:

Integration with Windows Explorer:

При выборе этой опции в контекстном меню Проводника Windows появится дополнительный пункт, позволяющий быстро проверить выделенные файлы.

Integration with Microsoft Outlook:

При выборе этой опции будет произведена интеграция с Microsoft Outlook , обеспечивающая автоматическую проверку входящей и исходящей почты на вирусы. Обратите внимание, что эта опция доступна только при наличии установленного Microsoft Outlook (не Outlook Express).

Download Source Code:

При выборе этой опции будет произведена автоматическая загрузка исходного кода программы из Интернет. Исходный код не обязателен для нормального функционирования антивируса, но может представлять интерес для программистов.

Затем вам нужно будет указать папку Главного меню для размещения ярлыков ClamWin. По умолчанию создается папка ClamWin Antivirus.

На следующем экране вам будет предложено обновить вирусные базы после завершения программы установки. Рекомендуется обновить вирусные базы при первой возможности. Так же на этом экране доступна опция, позволяющая создать ярлык ClamWin на Рабочем столе.

На последнем экране отображается информация о выбранном варианте установки. Для установки ClamWin с выбранными опциями нажмите Install. Чтобы изменить выбранные опции нажмите < Back .
В случае выбора пунктов Download Source Code или Download Virus Database Files, загрузка файлов будет осуществлена после завершения установки. Для этого необходимо подключение к Интернет.


Настройка

Для настройки ClamWin воспользуйтесь опцией Configure ClamWin контекстного меню значка на панели задач, или опцией Preferences меню Tools главного окна программы. Настройка осуществляется в диалоговом окне, имеющем девять вкладок. Нажатие кнопки OK сохраняет настройки и закрывает окно настройки. Кнопка Cancel закрывает окно настройки без сохранения изменений.

Описание каждой из вкладок приведено ниже:

Общие (General)

Эта вкладка контролирует поведение ClamWin при сканировании и его поведение при обнаружении инфицированного файла. Группа флажков Scanning Options управляет поведением ClamWin при проверке. Возможна любая комбинация выбранных опций.

  • Проверять вложенные папки (Scan In Subdirectories): При выборе данной опции ClamWin будет проверять не только выбранную папку, но и папки, вложенные в нее.

  • Показывать только зараженные файлы (Display Infected Files Only): При проверке ClamWin показывает имена сканируемых файлов. При выборе этой опции ClamWin будет показывать только имена инфицированных файлов. Выбор этой опции может увеличить скорость поверки.

  • Сообщать об обнаруженных вирусах (Display Warning When Virus Is Detected): При обнаружении вируса, в случае, если эта опция включена, будет отображено предупреждение.

Группа Infected Files задает поведение ClamWin в случае обнаружения вируса. Возможен выбор только одного варианта.

  • Только сообщить (Report Only): При выборе этой опции ClamWin только отобразит сообщение об обнаружении вируса.

  • Удалить (Remove): При выборе этой опции будет произведено удаление инфицированного файла без возможности восстановления. Файл не будет помещен в Корзину Windows.

  • Переместить в Карантин (Move To Quarantine Folder): При выборе этой опции инфицированные файлы помещаются в специальную папку. Для того, чтобы выбрать папку воспользуйтесь кнопкой ... При наличии в Карантине файла с аналогичным именем ClamWin переименует файл, добавив в конец его имени точку и порядковый номер. Например, в Карантине содержится файл eicar.com. Обнаружен вирус в другом файле, тоже носящем имя eicar.com. Тогда второй файл будет перемещен в Карантин и переименован в eicar.com.000, третий инфицированный файл с таким же названием получит имя eicar.com.001 и т.д.

Фильтры (Filters)
Эта вкладка позволяет настроить ClamWin на проверку только некоторых типов файлов или на игнорирование некоторых типов файлов. Комбинирование этих условий позволяет полностью настроить процесс сканирования.

Отдельные файлы могут быть отфильтрованы указанием полного пути, например C:/Path/to/folder/File.ext
Папки могут быть отфильтрованы указанием пути с символом * в конце, например
C:/Path/to/folder/*
Обратите внимание, что для разделения папок используется прямой (/), а не обратный (\) слеш.
Для более точной настройки можно использовать регулярные выражения. Они должны находиться в угловых скобках (<RegularExpression>). Информация о регулярных выражениях доступна в сети Интернет.
По умолчанию не проверяются следующие типы файлов:
*.dbx (используется для хранения электронной почты программой Outlook Express)
*.tbb (используется для хранения электронной почты программой The Bat!)
*.pst (используется для хранения данных программой Microsoft Outlook).

Сетевые обновления (Internet Updates)

Эта вкладка позволяет настроить обновление вирусных баз ClamWin. При выборе опции Enable Automatic Virus Database Updates ClamWin будет автоматически обновлять вирусные базы. Периодичность и время проверки могут быть настроены пользователем. Если в указанное время ClamWin не запущен (или компьютер выключен), обновление будет произведено при следующем запуске ClamWin (обычно при следующем включении компьютера). Единственным исключением являет установка обновлений по рабочим дням (workdays). В этом случае обновление не будет производиться до понедельника. Возможен ввод адреса сервера обновлений вручную. Для большинства пользователей рекомендуется использовать адрес по умолчанию (database.clamav.net). В случае, если у вас имеется обновляемая копия database.clamav.net на локальном сервере, рекомендуется ввести адрес локального сервера. Опция Update Virus Database On Logon позволяет проверять наличие обновлений при входе пользователя в систему.

Прокси-сервер (Proxy)

Если ваш компьютер подключен к Интернет через прокси-сервер, то необходимо произвести настройку. Большинство пользователей не используют прокси-сервер, и могут эту вкладку игнорировать.

Проверки по расписанию (Scheduled Scans)

На этой вкладке вы можете создать расписание проверок. ClamWin будет автоматически проверять указанные объекты в указанное время. Чтобы добавить проверку, нажмите кнопку Add, затем задайте описание, частоту, время, и проверяемую папку. Существующую проверку можно отредактировать, нажав кнопку Edit, или удалить, нажав Remove.

Назначенные проверки могут быть активированы кнопкой Activate или дезактивированы кнопкой Deactivate. Дезактивированная проверка в указанное время не выполняется.

Извещения по e-mail (Email Alerts)
ClamWin может отправлять извещения об обнаружении вируса по электронной почте. Для этого выберите опцию Send Email Alert On Virus Detection. Для корректного функционирования необходимо задать свойства используемого SMTP сервера, и информацию о сообщении (поля тема (Subject), от (From), кому (To))
Обратите внимание: некоторые SMTP серверы не требуют имени пользователя и пароля. В данном случае оставьте поля User Name и Password незаполненными.
Для проверки корректности настроек воспользуйтесь кнопкой отправки тестового сообщения Send Test Email.
При выборе этой опции ClamWin будет отсылать извещения по электронной почте всякий раз при обнаружении вируса. В извещении будет указано имя компьютера, с которого было отправлено данное извещение и копию протокола проверки.

Архивы (Archives)
ClamWin может проверить файлы в архивах (например .zip файлах) на наличие вирусов. Эта вкладка позволяет указать необходимость проверки файлов внутри архива, максимальный размер архивного файла, максимальное число извлекаемых файлов и максимальную степень вложенности архивов.
Обратите внимание, что проверка содержимого архивов может существенно снизить скорость проверки.

Расположение файлов (File Locations)

На этой вкладке задается расположение программ ClamScan (программы-сканера), FreshClam (программы обновления вирусных баз) и файлов вирусных баз. Пути указываются во время процедуры установки и, обычно, не требуют изменения. Не изменяйте эти настройки, если Вы не знаете, что Вы делаете. Это может привести к неработоспособности ClamWin.

Отчеты (Reports)

Здесь вы можете задать расположение и имена файлов отчетов. Большинство пользователей может оставить значения, предложенные по умолчанию. Так же вы можете активировать всплывающие предупреждения. Сброс флажка Display Pop-up Notification Messages In Taskbar подавит всплывающие окна, появляющиеся при удалении вируса, обновлении вирусных баз и т.д.

Дополнительно (Advanced)

На этой вкладке доступно четыре опции. Для большинства пользователей подойдут установки по умолчанию.

Treat Files As Mailboxes: При выборе этой опции ClamWin будет обрабатывать все файлы как сообщения электронной почты MIME (например Unix mailbox, файлы .eml, сохраненные программой Outlook Express)

Extract Attachments and Macros from MS Office Documents: При выборе этой опции будет производиться проверка на макровирусы в документах MS Office.
Limit Log File Size To: Ограничение размера файлов отчета.
Scanner Priority: Задание приоритета сканирования. В списке доступны Низкий (Low), Нормальный (Normal), и Высокий (High) приоритеты. Чем выше приоритет, тем больше ресурсов процессора используется для сканирования, что может привести к замедлению работы других программ. Низкий приоритет замедляет процесс сканирования.


Использование

Существует несколько способов использования ClamWin:

  • Запуск из Главного меню

  • Запуск из области задач

  • Использование проверок по расписанию

  • Интеграция с Outlook

  • Интеграция с Проводником Windows

В этом разделе будет описан каждый из способов

Запуск из Главного меню
По умолчанию, в процессе установки создается группа программ "ClamWin Antivirus" содержащая ярлык "Virus Scanner". При щелчке по нему появляется главное окно программы, показанное ниже:

Чтобы проверить файл или папку, просто выберите его в главном окне и нажмите кнопку [image]. Для выделения нескольких файлов или папок щелкните на их названии удерживая клавиши Control или Shift.

Запуск из области задач
Для запуска ClamWin из области задач дважды щелкните левой кнопкой мыши по значку программы [image] или выберите Open ClamWin из контекстного меню, показанного ниже. Контекстное меню позволяет получить доступ к некоторым функциям ClamWin.
Download Virus Database Update: Запуск обновления вирусных баз.
Configure ClamWin: Открывает окно настроек
Scheduler: В этом подменю вы можете настроить запланированные проверки.
Display Reports: С помощью этого подменю можно просмотреть протоколы обновления и проверки.

Назначенные проверки могут быть настроены в диалоговом окне настроек. При указании времени проверки ClamWin будет автоматически выполнять проверку не отвлекая пользователя. При обнаружении появится всплывающее предупреждение возле значка ClamWin в области задач (примечание: всплывающие предупреждения не работают в Windows 98). Действие, предпринимаемое ClamWin к инфицированному объекту задается установками на вкладке General диалога настроек.

Интеграция с Outlook
При наличии установленного Microsoft Outlook и выборе опции Integration with Microsoft Outlook во время установки ClamWin, будет проводиться автоматическая проверка входящей и исходящей электронной почты на наличие вирусов. В случае обнаружения файла, зараженного вирусом, он будет заменен файлом протокола.

Интеграция с Проводником Windows
При выборе опции Integration with Windows Explorer во время установки в контекстное меню Проводника будет добавлен пункт Scan For Viruses With ClamWin. Для проверки достаточно щелкнуть правой кнопкой мыши на выбранном файле или папке.


Дополнительные возможности

Этот раздел содержит дополнительную информацию для опытных пользователей.

Проверка на вирусы из командной строки

ClamWin способен работать из командной строки или пакетного файла. Для получения полного списка ключей перейдите в папку, содержащую исполняемые файлы ClamWin (по умолчанию "C:\Program Files\ClamWin\bin") и запустите

clamscan.exe с ключом --help

Папка, содержащая файлы вирусных баз должна быть указана с помощью ключа --database=FILE/DIR.

Например, для проверки всего диска C: нужно будет набрать:

clamscan.exe --database="C:\Program Files\ClamWin\db" --recursive C:\

Не забывайте использовать ключ --recursive для проверки вложенных папок.

При работе из командной строки ClamWin возвращает значение. При обнаружении вируса возвращается 1, если вирусы не обнаружены возвращается 0, другие цифры сигнализируют об ошибке.

Обновление баз из командной строки

ClamWin использует программу freshclam.exe для обновления вирусных баз. Данная программа, как и clamscan.exe может быть запущена из командной строки. Для получения полного списка ключей перейдите в папку, содержащую исполняемые файлы ClamWin (по умолчанию "C:\Program Files\ClamWin\bin") и запустите freshclam.exe с ключом --help

Обязательно должны быть указана папка вирусных баз и файл настроек. ClamWin автоматически генерирует файл настроек программы freshclam, поэтому вам необходимо создать собственный файл. Файл настроек представляет собой неформатированный текст. Для получения подробной информации о создании файлов настроек рекомендуется ознакомиться с документацией ClamAV . Пример подобного файла приведен ниже (строки, начинающиеся с # являются комментариями):

# Адрес сервера обновлений
# Возможно указание нескольких адресов. Будет выбран первый из
# доступных серверов.
DatabaseMirror database.clamav.net
# Количество попыток связаться с сервером до выбора другого зеркала.
MaxAttempts 3

После создания файла настроек freshclam, обновление возможно выполнением команды, похожей на:

freshclam --datadir="C:\Documents and Settings\All Users\.clamwin\db" --config-file="C:\Program Files\ClamWin\bin\freshclam.conf"

Обновление баз с локального сервера
Если ClamWin запущен у вас на нескольких компьютерах, связанных в сеть, возможно провести обновление вирусных баз на всех машинах с одной из них. Для этого необходимо, чтобы один из компьютеров имел доступ в Интернет. Существует два способа реализации обновления баз с локального сервера.
Первый (рекомендуемый) метод требует наличия запущенного веб-сервера. В корневом каталоге сервера должны находиться файлы main.cvd и daily.cvd. На вкладке Internet Updates в поле Download Site введите IP адрес сервера или доменное имя.
Второй метод заключается в создании пакетного файла или программы, копирующих файлы main.cvd и daily.cvd с сервера в соответствующую папку, перезаписывая существующие копии. Для регулярного проведения обновления вы можете воспользоваться Планировщиком Задач Windows. При использовании этого метода отключите опцию Enable Automatic Virus Database Updates.


Часто задаваемые вопросы

В: Почему в отчете об обновлении появляется следующее сообщение? ClamWin обновляется регулярно:
Your ClamAV installation is OUTDATED - please update immediately!

О: ClamWin является графическим интерфейсом антивируса ClamAV. Данное сообщение появляется при наличии более новой версии ClamAV. Обновление ClamWin приведет к исчезновению этого сообщения. Программа автоматического обновления ClamWin способна обновлять только файлы вирусных баз, а не саму программу. Автоматическое обновление программы находится в стадии разработки.

В: Доступны ли локализованные версии? Могу ли я перевести интерфейс ClamWin на другой язык?

О: В настоящее время единственным языком интерфейса является английский. Перевод ClamWin на другие языки затруднителен. B дальнейшем (вероятно, в версии 1.0) будет добавлена возможность перевода интерфейса ClamWin. Однако доступны переводы документации в разделе Documents .

Если вы захотите перевести руководство пользователя ClamWin и/или часто задаваемые вопросы, свяжитесь с Russ Phillips по адресу avantman42@users.sourceforge.net

В: Могу ли я обновить установленную версию ClamWin?

О: Да, просто запустите программу установки новой версии и установите ее поверх существующей.

В: Почему опция Integration with Microsoft Outlook не видна во время установки?

О: Эта опция доступна только при наличии установленного Microsoft Outlook. Обратите внимание, что Outlook (компонент Microsoft Office) и Outlook Express являются разными программами. ClamWin не интегрируется с Outlook Express.

В: Способен ли ClamWin проверять файлы при их открытии/выполнении (выступать в роли резидентного сканера)?

О: Нет. Однако при наличии интеграции с Проводником Windows вы можете проверить файлы из их контекстного меню, выбрав "Scan For Viruses With ClamWin"

В: Как проверить работоспособность антивируса?

О: Загрузите тестовый файл EICAR http://www.eicar.org/anti_virus_test_file.htm

Этот файл не является вирусом. Любая антивирусная программа должна обнаруживать его и сообщать об обнаружении вируса. ClamWin сообщит об обнаружении вируса "Eicar-Test-Signature". Данный файл представляет собой DOS программу, выводящую на экран сообщение "EICAR-STANDARD-ANTIVIRUS-TEST-FILE!"

В: Я установил ClamWin с интеграцией с Outlook. Почему в Outlook не произошло никаких изменений?

О: ClamWin не отображается как надстройка. Однако, при правильной установке в меню Справка будет добавлен пункт "About ClamWin".

В: Возможна ли проверка входящей и исходящей электронной почты?

A: При наличии интеграции с Outlook, входящая и исходящая почта проверяются автоматически при открытии. В случае обнаружения файла, зараженного вирусом, он будет заменен файлом протокола.

В: Как я могу сообщить о неизвестном вирусе?

О: ClamWin использует вирусные базы антивируса ClamAV ( www.clamav.net ). Вирусы, не включенные в базу можно быть отправить, используя форму на странице www.clamav.net/sendvirus.html .

Перед отправкой вируса убедитесь, что у вас установлены самые свежие вирусные базы. Там же можно сообщить о ложном срабатывании.


Решение проблем

Проблема: При попытке отправки тестового сообщения по электронной почте, появляются подобные сообщения:

Could not send the email. Please ensure you are connected to the internet.

Error: SMTP instance has no attribute 'sock'

Решение: Исправьте настройки SMTP сервера. Обратите внимание, что многие провайдеры не требуют имя пользователя и пароль для доступа к SMTP серверу. Попробуйте очистить поля User Name и Password.

Проблема: Сообщение об ошибке

Unable to create temporary directory

Эта ошибка может возникнуть если на компьютере ранее был установлен, а потом удален Cygwin. Если вы больше не нуждаетесь в установленном Cygwin, удалите из реестра раздел

HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions.

После удаления этого раздела переустановите ClamWin. Если же вам нужен Cygwin, создайте в реестре раздел

HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts2\ /tmp

И добавльте в него следующие параметры:

Имя: flags

Тип: dword

Значение: 0000000a

Имя: native

Тип: string

Значение: "C:\\Documents and Settings\\All Users\\Local Settings\\Temp"

или "C:\\Temp"

Значение параметра "native" может указывать на любую папку, в которую разрешена запись.

Проблема: Outlook 2000 не обнаруживается во время установки

Программа установки не способна обнаружить Outlook 2000 без установленного Service Pack 1. Данная ошибка будет исправлена в последующих версиях. Для обхода этой ошибки создайте в реестре раздел HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook и повторите установку ClamWin.

Проблема: Невозможно установить ClamWin в Windows XP без прав администратора

В Windows XP ClamWin может быть установлен только пользователем имеющим права администратора. Данная ошибка будет исправлена в последующих версиях.

Почтовые программы хранят сообщения в одном файле

Некоторые почтовые клиенты, например The Bat! Хранят все сообщения в одном файле, а другие, например Mozilla Thunderbird, для хранения каждого из писем выделяют отдельный файл. Если ClamWin обнаружит вирус, прикрепленный к письму, то посчитает, что весь файл (т.е. все сообщения в этом файле) заражен. Поэтому файл будет удален или перемещен в Карантин. Возможно, вы захотите исключить подобные файлы из списка проверяемых.

Конфликты с ActivePython

Установленные python 2.3 и pywin32-201 (http://sourceforge.net/projects/pywin32/) не вызывают конфликтов. Похоже, что ActiveState python, поставляемый с win32all-163 (pywin32) взывают конфликт библиотек. Для разрешения проблемы при наличии установленного ActivePython 2.3, необходимо установить pywin32-201.


Как запустить ClamWin с CD или USB

Введение

Данное мини-руководство содержит инструкции по созданию компакт-диска или USB-flash (в дальнейшем носитель) содержащего ClamWin для проверки компьютера с установленной Windows без необходимости установки ClamWin. Обратите внимание, что создаваемый носитель не является загрузочным и может быть использован только при загруженной Windows. Данное руководство было создано в ответ на запрос функции, поступивший на страницу проекта ClamWin ( RFE 945882 )

На компьютере, используемом для создания носителя, должен быть установлен ClamWin. Так же должна поддерживаться запись на выбранный носитель.

Подготовка

Начните с установки последней версии ClamWin, загрузите свежие вирусные базы. При возникновении проблем, ознакомьтесь с Руководством пользователя ClamWin. Обратите внимание, что функциональность созданного CD ограничена. Вы не сможете обновлять вирусные базы без создания нового диска.

Копирование папок

Создайте временную папку для хранения переносимых файлов, например C:\ClamWin-CD.
В ней создайте папку ClamWin.
Скопируйте содержимое программной папки ClamWin в C:\ClamWin-CD\ClamWin. По умолчанию, программная папка ClamWin находится в C:\Program Files\ClamWin
Скопируйте папку вирусных баз ClamWin в C:\ClamWin-CD\ClamWin. Путь к папке с вирусными базами вы можете найти на вкладке File Locations Настроек.

Таким образом, у вас должно получиться такое дерево папок:

C:\ClamWin-CD
C:\ClamWin-CD\ClamWin\bin
C:\ClamWin-CD\ClamWin\db
C:\ClamWin-CD\ClamWin\lib

Редактирование настроек и Создание файлов автозапуска

Откройте файл C:\ClamWin-CD\ClamWin\bin\ClamWin.conf текстовым редактором, например Блокнотом. Отредактируйте его, как показано ниже:

[ClamAV]
clamscan=clamscan.exe
freshclam=freshclam.exe
database=..\db
quarantinedir=
logfile=
[Updates]
dbupdatelogfile=
time=

В папке C:\ClamWin-CD создайте два текстовых файла с именами autorun.inf и RUN_ME.vbs. Убедитесь, что данные файлы не имеют расширения .txt.
Отредактируйте autorun.inf вставив только три строки, указанные ниже:

[autorun]
OPEN=RUN_ME.vbs
icon=ClamWin\bin\img\TrayIcon.ico

Отредактируйте RUN_ME.vbs вставив только три строки, указанные ниже:

set oShell = WScript.CreateObject ("WScript.Shell")
oShell.Run "ClamWin\bin\ClamWin.exe"
set oShell = Nothing

Копирование файлов на CD/USB

Теперь необходимо просто скопировать содержимое папки C:\ClamWin-CD на подходящий носитель. Не копируйте саму папку C:\ClamWin-CD.

Использование CD/USB

Для использования созданного носителя вставьте его в проверяемый компьютер. Если Windows поддерживает автозагрузку, будет произведен автоматический запуск ClamWin. В случае отключенной автозагрузки запустите файл RUN_ME.vbs. Если же данный способ не сработал, значит на компьютере отключен или не установлен Windows Script Host. В таком случае можно запустить ClamWin вручную двойным щелчком на файле ClamWin.exe расположенном в папке ClamWin\bin.

ClamWin должен функционировать нормально, однако работа с CD налагает определенные ограничения:

  • Файлы не переносятся в Карантин

  • Сетевые обновления недоступны

  • Невозможно изменение настроек

Лицензия

Данный документ лицензируется согласно требованиям Creative Commons License .


Стандартная общественная лицензия GNU

Преамбула

Большинство лицензий на программное обеспечение лишает вас права распространять и вносить изменения в это программное обеспечение. Стандартная Общественная Лицензия GNU, напротив, разработана с целью гарантировать вам право совместно использовать и вносить изменения в свободное программное обеспечение, т.е. обеспечить свободный доступ к программному обеспечению для всех пользователей. Условия настоящей Стандартной Общественной Лицензии применяются к большей части программного обеспечения Free Software Foundation, а также к любому другому программному обеспечению по желанию его автора. (К некоторому программному обеспечению Free Software Foundation применяются условия Стандартной Общественной Лицензии GNU для Библиотек). Вы также можете применять Стандартную Общественную Лицензию к разработанному вами программному обеспечению.

Говоря о свободном программном обеспечении, мы имеем в виду свободу, а не безвозмездность. Настоящая Стандартная Общественная Лицензия разработана с целью гарантировать вам право распространять экземпляры свободного программного обеспечения (и при желании получать за это вознаграждение), право получать исходный текст программного обеспечения или иметь возможность его получить, право вносить изменения в программное обеспечение или использовать его части в новом свободном программном обеспечении, а также право знать, что вы имеете все вышеперечисленные права.

Чтобы защитить ваши права, мы вводим ряд ограничений с тем, чтобы никто не имел возможности лишить вас этих прав или обратиться к вам с предложением отказаться от этих прав. Данные ограничения налагают на вас определенные обязанности в случае, если вы распространяете экземпляры программного обеспечения или модифицируете программное обеспечение.

Например, если вы распространяете экземпляры такого программного обеспечения за плату или бесплатно, вы обязаны передать новым обладателям все права в том же объеме, в каком они принадлежат вам. Вы обязаны обеспечить получение новыми обладателями программы ее исходного текста или возможность его получить. Вы также обязаны ознакомить их с условиями настоящей Лицензии.

Для защиты ваших прав мы: (1) оставляем за собой авторские права на программное обеспечение и (2) предлагаем вам использовать настоящую Лицензию, в соответствии с условиями которой вы вправе воспроизводить, распространять и/или модифицировать программное обеспечение.

Кроме того, для защиты как нашей репутации, так и репутации других авторов программного обеспечения, мы уведомляем всех пользователей, что на данное программное обеспечение никаких гарантий не предоставляется. Те, кто приобрел программное обеспечение, с внесенными в него третьими лицами изменениями, должны знать, что они получают не оригинал, в силу чего автор оригинала не несет ответственности за ошибки в работе программного обеспечения, допущенные третьими лицами при внесении изменений.

Наконец, программное обеспечение перестает быть свободным в случае, если лицо приобретает на него исключительные права. Недопустимо, чтобы лица, распространяющие свободное программное обеспечение, могли приобрести исключительные права на использование данного программного обеспечения и зарегистрировать их в Патентном ведомстве. Чтобы избежать этого, мы заявляем, что обладатель исключительных прав обязан предоставить любому лицу права на использование программного обеспечения либо не приобретать исключительных прав вообще.

Ниже изложены условия воспроизведения, распространения и модификации программного обеспечения.

Условия воспроизведения, распространения и модификации

0. Условия настоящей Лицензии применяются ко всем видам программного обеспечения или любому иному произведению, которое содержит указание правообладателя на то, что данное произведение может распространяться на условиях Стандартной Общественной Лицензии. Под термином "Программа" далее понимается любое подобное программное обеспечение или иное произведение. Под термином "произведение, производное от Программы" понимается Программа или любое иное производное произведение в соответствии с законодательством об авторском праве, т.е. произведение, включающее в себя Программу или ее часть, как с внесенными в ее текст изменениями, так и без них и/или переведенную на другой язык. (Здесь и далее, понятие "модификация" включает в себя понятие перевода в самом широком смысле). Каждый приобретатель экземпляра Программы именуется в дальнейшем "Лицензиат".

Действие настоящей Лицензии не распространяется на осуществление иных прав, кроме воспроизведения, распространения и модификации программного обеспечения. Не устанавливается ограничений на запуск Программы. Условия Лицензии распространяются на выходные данные из Программы только в том случае, если их содержание составляет произведение, производное от Программы (независимо от того, было ли такое произведение создано в результате запуска Программы). Это зависит от того, какие функции выполняет Программа.

1. Лицензиат вправе изготовлять и распространять экземпляры исходного текста Программы в том виде, в каком он его получил, без внесения в него изменений на любом носителе, при соблюдении следующих условий: на каждом экземпляре помещен знак охраны авторского права и уведомление об отсутствии гарантий; оставлены без изменений все уведомления, относящиеся к настоящей Лицензии и отсутствию гарантий; вместе с экземпляром Программы приобретателю передается копия настоящей Лицензии.

Лицензиат вправе взимать плату за передачу экземпляра Программы, а также вправе за плату оказывать услуги по гарантийной поддержке Программы.

2. Лицензиат вправе модифицировать свой экземпляр или экземпляры Программы полностью или любую ее часть. Данные действия Лицензиата влекут за собой создание произведения, производного от Программы. Лицензиат вправе изготовлять и распространять экземпляры такого произведения, производного от Программы, или собственно экземпляры изменений в соответствии с пунктом 1 настоящей Лицензии при соблюдении следующих условий:

  1. файлы, измененные Лицензиатом, должны содержать хорошо заметную пометку, что они были изменены, а также дату внесения изменений;

  2. при распространении или публикации Лицензиатом любого произведения, которое содержит Программу или ее часть или является производным от Программы или от ее части, Лицензиат обязан передавать права на использование данного произведения третьим лицам на условиях настоящей Лицензии, при этом Лицензиат не вправе требовать уплаты каких-либо лицензионных платежей. Распространяемое произведение лицензируется как одно целое;

  3. если модифицированная Программа при запуске обычно читает команды в интерактивном режиме, Лицензиат обязан обеспечить вывод на экран дисплея или печатающее устройство сообщения, которое должно включать в себя:

знак охраны авторского права;

уведомление об отсутствии гарантий на Программу (или иное, если Лицензиат предоставляет гарантии);

указание на то, что пользователи вправе распространять экземпляры Программы в соответствии с условиями настоящей Лицензии, а также на то, каким образом пользователь может ознакомиться с текстом настоящей Лицензии. (Исключение: если оригинальная Программа является интерактивной, но не выводит в своем обычном режиме работы сообщение такого рода, то вывод подобного сообщения произведением, производным от Программы, в этом случае не обязателен).

Вышеуказанные условия применяются к модифицированному произведению, производному от Программы, в целом. В случае если отдельные части данного произведения не являются производными от Программы, являются результатом творческой деятельности и могут быть использованы как самостоятельное произведение, Лицензиат вправе распространять отдельно такое произведение на иных лицензионных условиях. В случае если Лицензиат распространяет вышеуказанные части в составе произведения, производного от Программы, то условия настоящей Лицензии применяются к произведению в целом, при этом права, приобретаемые сублицензиатами на основании Лицензии, передаются им в отношении всего произведения, включая все его части, независимо от того, кто является их авторами.

Целью настоящего пункта 2 не является заявление прав или оспаривание прав на произведение, созданное исключительно Лицензиатом. Целью настоящего пункта является обеспечение права контролировать распространение произведений, производных от Программы, и составных произведений, производных от Программы.

Размещение произведения, которое не является производным от Программы, на одном устройстве для хранения информации или носителе вместе с Программой или произведением, производным от Программы, не влечет за собой распространения условий настоящей Лицензии на такое произведение.

3. Лицензиат вправе воспроизводить и распространять экземпляры Программы или произведения, которое является производным от Программы, в соответствии с пунктом 2 настоящей Лицензии, в виде объектного кода или в исполняемой форме в соответствии с условиями п.п.1 и 2 настоящей Лицензии при соблюдении одного из перечисленных ниже условий:

  1. к экземпляру должен прилагаться соответствующий полный исходный текст в машиночитаемой форме, который должен распространяться в соответствии с условиями п.п. 1 и 2 настоящей Лицензии на носителе, обычно используемом для передачи программного обеспечения, либо

  2. к экземпляру должно прилагаться действительное в течение трех лет предложение в письменной форме к любому третьему лицу передать за плату, не превышающую стоимость осуществления собственно передачи, экземпляр соответствующего полного исходного текста в машиночитаемой форме в соответствии с условиями п.п. 1 и 2 настоящей Лицензии на носителе, обычно используемом для передачи программного обеспечения, либо

  3. к экземпляру должна прилагаться полученная Лицензиатом информация о предложении, в соответствии с которым можно получить соответствующий исходный текст. (Данное положение применяется исключительно в том случае, если Лицензиат осуществляет некоммерческое распространение программы, при этом программа была получена самим Лицензиатом в виде объектного кода или в исполняемой форме и сопровождалась предложением, соответствующим условиям пп.b п.3 настоящей Лицензии).

Под исходным текстом произведения понимается такая форма произведения, которая наиболее удобна для внесения изменений. Под полным исходным текстом исполняемого произведения понимается исходный текст всех составляющих произведение модулей, а также всех файлов, связанных с описанием интерфейса, и сценариев, предназначенных для управления компиляцией и установкой исполняемого произведения. Однако, в качестве особого исключения, распространяемый исходный текст может не включать того, что обычно распространяется (в виде исходного текста или в бинарной форме) с основными компонентами (компилятор, ядро и т.д.) операционной системы, в которой работает исполняемое произведение, за исключением случаев, когда исполняемое произведение сопровождается таким компонентом.

В случае если произведение в виде объектного кода или в исполняемой форме распространяется путем предоставления доступа для копирования его из определенного места, обеспечение равноценного доступа для копирования исходного текста из этого же места удовлетворяет требованиям распространения исходного текста, даже если третьи лица при этом не обязаны копировать исходный текст вместе с объектным кодом произведения.

4. Лицензиат вправе воспроизводить, модифицировать, распространять или передавать права на использование Программы только на условиях настоящей Лицензии. Любое воспроизведение, модификация, распространение или передача прав на иных условиях являются недействительными и автоматически ведут к расторжению настоящей Лицензии и прекращению всех прав Лицензиата, предоставленных ему настоящей Лицензией. При этом права третьих лиц, которым Лицензиат в соответствии с настоящей Лицензией передал экземпляры Программы или права на нее, сохраняются в силе при условии полного соблюдения ими настоящей Лицензии.

5. Лицензиат не обязан присоединяться к настоящей Лицензии, поскольку он ее не подписал. Однако только настоящая Лицензия предоставляет право распространять или модифицировать Программу или произведение, производное от Программы. Подобные действия нарушают действующее законодательство, если они не осуществляются в соответствии с настоящей Лицензией. Если Лицензиат внес изменения или осуществил распространение экземпляров Программы или произведения, производного от Программы, Лицензиат тем самым подтвердил свое присоединение к настоящей Лицензии в целом, включая условия, определяющие порядок воспроизведения, распространения или модификации Программы или произведения, производного от Программы.

6. При распространении экземпляров Программы или произведения, производного от Программы, первоначальный лицензиар автоматически передает приобретателю такого экземпляра право воспроизводить, распространять и модифицировать Программу в соответствии с условиями настоящей Лицензии. Лицензиат не вправе ограничивать каким-либо способом осуществление приобретателями полученных ими прав. Лицензиат не несет ответственности за несоблюдение условий настоящей Лицензии третьими лицами.

7. Лицензиат не освобождается от исполнения обязательств в соответствии с настоящей Лицензией в случае, если в результате решения суда или заявления о нарушении исключительных прав или в связи с наступлением иных обстоятельств, не связанных непосредственно с нарушением исключительных прав, на Лицензиата на основании решения суда, договора или ином основании возложены обязательства, которые противоречат условиям настоящей Лицензии. В этом случае Лицензиат не вправе распространять экземпляры Программы, если он не может одновременно исполнить условия настоящей Лицензии и возложенные на него указанным выше способом обязательства. Например, если по условиям лицензионного соглашения сублицензиатам не может быть предоставлено право бесплатного распространения экземпляров Программы, которые они приобрели напрямую или через третьих лиц у Лицензиата, то в этом случае Лицензиат обязан отказаться от распространения экземпляров Программы.

Если любое положение настоящего пункта при наступлении конкретных обстоятельств будет признано недействительным или неприменимым, настоящий пункт применяется за исключением такого положения. Настоящий пункт применяется в целом при прекращении вышеуказанных обстоятельств или их отсутствии.

Целью данного пункта не является принуждение Лицензиата к нарушению патента или заявления на иные права собственности или к оспариванию действительности такого заявления. Единственной целью данного пункта является защита неприкосновенности системы распространения свободного программного обеспечения, которая обеспечивается за счет общественного лицензирования. Многие люди внесли свой щедрый вклад в создание большого количества программного обеспечения, которое распространяется через данную систему в надежде на ее длительное и последовательное применение. Лицензиат не вправе вынуждать автора распространять программное обеспечение через данную систему. Право выбора системы распространения программного обеспечения принадлежит исключительно его автору.

Настоящий пункт 7 имеет целью четко определить те цели, которые преследуют все остальные положения настоящей Лицензии.

8. В том случае если распространение и/или использование Программы в отдельных государствах ограничено соглашениями в области патентных или авторских прав, первоначальный правообладатель, распространяющий Программу на условиях настоящей Лицензии, вправе ограничить территорию распространения Программы, указав только те государства, на территории которых допускается распространение Программы без ограничений, обусловленных такими соглашениями. В этом случае такое указание в отношении территорий определенных государств признается одним из условий настоящей Лицензии.

9. Free Software Foundation может публиковать исправленные и/или новые версии настоящей Стандартной Общественной Лицензии. Такие версии могут быть дополнены различными нормами, регулирующими правоотношения, которые возникли после опубликования предыдущих версий, однако в них будут сохранены основные принципы, закрепленные в настоящей версии.

Каждой версии присваивается свой собственный номер. Если указано, что Программа распространяется в соответствии с определенной версией, т.е. указан ее номер, или любой более поздней версией настоящей Лицензии, Лицензиат вправе присоединиться к любой из этих версий Лицензии, опубликованных Free Software Foundation. Если Программа не содержит такого указания на номер версии Лицензии Лицензиат вправе присоединиться к любой из версий Лицензии, опубликованных когда-либо Free Software Foundation.

10. В случае если Лицензиат намерен включить часть Программы в другое свободное программное обеспечение, которое распространяется на иных условиях, чем в настоящей Лицензии, ему следует испросить письменное разрешение на это у автора программного обеспечения. Разрешение в отношении программного обеспечения, права на которое принадлежат Free Software Foundation, следует испрашивать у Free Software Foundation. В некоторых случаях Free Software Foundation делает исключения. При принятии решения Free Software Foundation будет руководствоваться двумя целями: сохранение статуса свободного для любого произведения, производного от свободного программного обеспечения Free Software Foundation и обеспечение наиболее широкого совместного использования программного обеспечения.

ОТСУТСТВИЕ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ

11. ПОСКОЛЬКУ НАСТОЯЩАЯ ПРОГРАММА РАСПРОСТРАНЯЕТСЯ БЕСПЛАТНО, ГАРАНТИИ НА НЕЕ НЕ ПРЕДОСТАВЛЯЮТСЯ В ТОЙ СТЕПЕНИ, В КАКОЙ ЭТО ДОПУСКАЕТСЯ ПРИМЕНИМЫМ ПРАВОМ. НАСТОЯЩАЯ ПРОГРАММА ПОСТАВЛЯЕТСЯ НА УСЛОВИЯХ "КАК ЕСТЬ". ЕСЛИ ИНОЕ НЕ УКАЗАНО В ПИСЬМЕННОЙ ФОРМЕ, АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ НЕ ПРИНИМАЕТ НА СЕБЯ НИКАКИХ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ, КАК ЯВНО ВЫРАЖЕННЫХ, ТАК И ПОДРАЗУМЕВАЕМЫХ, В ОТНОШЕНИИ ПРОГРАММЫ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМУЮ ГАРАНТИЮ ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ И ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ, А ТАКЖЕ ЛЮБЫЕ ИНЫЕ ГАРАНТИИ. ВСЕ РИСКИ, СВЯЗАННЫЕ С КАЧЕСТВОМ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПРОГРАММЫ, НЕСЕТ ЛИЦЕНЗИАТ. В СЛУЧАЕ ЕСЛИ В ПРОГРАММЕ БУДУТ ОБНАРУЖЕНЫ НЕДОСТАТКИ, ВСЕ РАСХОДЫ, СВЯЗАННЫЕ С ТЕХНИЧЕСКИМ ОБСЛУЖИВАНИЕМ, РЕМОНТОМ ИЛИ ИСПРАВЛЕНИЕМ ПРОГРАММЫ, НЕСЕТ ЛИЦЕНЗИАТ.

12. ЕСЛИ ИНОЕ НЕ ПРЕДУСМОТРЕНО ПРИМЕНЯЕМЫМ ПРАВОМ ИЛИ НЕ СОГЛАСОВАНО СТОРОНАМИ В ДОГОВОРЕ В ПИСЬМЕННОЙ ФОРМЕ, АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ, КОТОРЫЙ МОДИФИЦИРУЕТ И/ИЛИ РАСПРОСТРАНЯЕТ ПРОГРАММУ НА УСЛОВИЯХ НАСТОЯЩЕЙ ЛИЦЕНЗИИ, НЕ НЕСЕТ ОТВЕТСТВЕННОСТИ ПЕРЕД ЛИЦЕНЗИАТОМ ЗА УБЫТКИ, ВКЛЮЧАЯ ОБЩИЕ, РЕАЛЬНЫЕ, ПРЕДВИДИМЫЕ И КОСВЕННЫЕ УБЫТКИ (В ТОМ ЧИСЛЕ УТРАТУ ИЛИ ИСКАЖЕНИЕ ИНФОРМАЦИИ, УБЫТКИ, ПОНЕСЕННЫЕ ЛИЦЕНЗИАТОМ ИЛИ ТРЕТЬИМИ ЛИЦАМИ, НЕВОЗМОЖНОСТЬ РАБОТЫ ПРОГРАММЫ С ЛЮБОЙ ДРУГОЙ ПРОГРАММОЙ И ИНЫЕ УБЫТКИ). АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ В СООТВЕТСТВИИ С НАСТОЯЩИМ ПУНКТОМ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ДАЖЕ В ТОМ СЛУЧАЕ, ЕСЛИ ОНИ БЫЛИ ПРЕДУПРЕЖДЕНЫ О ВОЗМОЖНОСТИ ВОЗНИКНОВЕНИЯ ТАКИХ УБЫТКОВ.

Порядок применения условий Стандартной Общественной Лицензии к созданной вами программе

Если вы создали новую программу и хотите, чтобы она принесла наибольшую пользу обществу, лучший способ достичь этого - сделать вашу программу свободной, когда каждый сможет распространять ее и вносить в нее изменения в соответствии с условиями настоящей Лицензии.

В этих целях Программа должна содержать приведенное ниже уведомление. Наиболее правильным будет поместить его в начале исходного текста каждого файла для максимально ясного указания на то, что гарантии на данную программу не предоставляются. Каждый файл в любом случае должен содержать знак охраны авторского права и пояснение, где можно ознакомиться с полным текстом уведомления.

[одна строка с наименованием Программы и кратким описанием ее назначения]

© имя (наименование) автора или иного правообладателя, год первого опубликования программы

Данная программа является свободным программным обеспечением. Вы вправе распространять ее и/или модифицировать в соответствии с условиями версии 2 либо по вашему выбору с условиями более поздней версии Стандартной Общественной Лицензии GNU, опубликованной Free Software Foundation.

Мы распространяем данную программу в надежде на то, что она будет вам полезной, однако НЕ ПРЕДОСТАВЛЯЕМ НА НЕЕ НИКАКИХ ГАРАНТИЙ, в том числе ГАРАНТИИ ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ и ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ. Для получения более подробной информации ознакомьтесь со Стандартной Общественной Лицензией GNU.

Вместе с данной программой вы должны были получить экземпляр Стандартной Общественной Лицензии GNU. Если вы его не получили, сообщите об этом в Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Также укажите, как можно связаться с вами по электронной или обычной почте.

Если программа работает в интерактивном режиме, сделайте так, чтобы при запуске в интерактивном режиме выводилось короткое сообщение в соответствии с образцом:

Gnomovision version 69, © имя автора, год первого опубликования программы

Gnomovision распространяется БЕЗ ВСЯКИХ ГАРАНТИЙ; чтобы ознакомиться с более подробной информацией, наберите "show w". Данная программа является свободным программным обеспечением и вы можете распространять ее в соответствии с условиями Стандартной Общественной Лицензии GNU. Для получения более подробной информации, наберите "show c".

При введении предлагаемых команд "show w" и "show c" на экран должны выводиться соответствующие пункты Стандартной Общественной Лицензии. Не обязательно использовать именно команды "show w" и "show c". В зависимости от функций программы, команды могут вызываться нажатием кнопки мыши или быть добавлены в меню программы.

Если вы создали программу в порядке выполнения служебных обязанностей или служебного задания работодателя либо для образовательного учреждения (школы, ВУЗа и т.д.) в период обучения или работы в данном образовательном учреждении, вам следует получить в случае необходимости письменный отказ от исключительных прав на использование данной программы. Нижеприведенный текст вы можете использовать в качестве образца, заменив соответствующие имена и наименования:

ЗАО "АБВ" настоящим отказывается от всех исключительных прав на использование программы для ЭВМ "Gnomovision", автором которой является Иванов Алексей Петрович, и передает все исключительные права на использование указанной программы ее автору, Иванову Алексею Петровичу.

Подпись руководителя организации, печать, 1 января 2001г.

[Фамилия, Имя, Отчество], Директор

Стандартная Общественная Лицензия GNU запрещает включать вашу программу в программы, использование которых ограничено их правообладателями. Если ваша программа является библиотекой подпрограмм, вероятно, более полезным будет разрешить связывание программ, использование которых ограничено их правообладателями, с вашей библиотекой. В этом случае вам следует использовать Стандартную Общественную Лицензию GNU для Библиотек вместо настоящей Лицензии.


GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software - to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU General Public License Terms and Conditions for Copying, Distribution and Modification

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

No Warranty

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

<one line to give the program's name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'. This is free software, and you are welcome to redistribute it under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items - whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision' (which makes passes at compilers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989 Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.